Join for FREE
It only takes a minute!
Magnifying the passion for nature. Zeiss Victory Harpia 95. New!

Welcome to BirdForum.
BirdForum is the net's largest birding community, dedicated to wild birds and birding, and is absolutely FREE! You are most welcome to register for an account, which allows you to take part in lively discussions in the forum, post your pictures in the gallery and more.

Reply
 
Thread Tools Rate Thread
Old Tuesday 27th June 2017, 22:32   #1
Binoseeker
Mostly using spectacles (myopic) with binoculars.
 
Binoseeker's Avatar

 
Join Date: Jun 2012
Location: Sweden
Posts: 521
New firmware version out, Metabones, Canon EF-lens on MFT

Name: Firmware update V2.8 for for Canon EF to Micro Four Thirds Smart AdapterTM/Speed BoosterTM
Release date: 26 Jun 2017
Benefits and improvements:
Fixed smooth iris support for 40/2.8 STM, 50/1.8 STM and Sigma 50-100/1.8 DC HSM Art 016.
Fixed AF issue with EF-S 10-18mm f/4.5-5.6 IS STM and EF-S 18-135/3.5-5.6 IS Nano USM lenses.
Fixed regression with EF Extender 1.4x not being recognized when used with fixed focal length lenses.

Last edited by Binoseeker : Tuesday 27th June 2017 at 22:34.
Binoseeker is offline  
Reply With Quote

BF Supporter 2012 Support BirdForum With A Donation

Old Wednesday 28th June 2017, 20:14   #2
DanC.Licks
AKA Daniel Bradley
 
DanC.Licks's Avatar

 
Join Date: Jul 2012
Location: Austria
Posts: 1,713
http://e-group.uk.net/forum/showthread.php?t=45423
DanC.Licks is offline  
Reply With Quote
Old Wednesday 5th July 2017, 20:14   #3
DanC.Licks
AKA Daniel Bradley
 
DanC.Licks's Avatar

 
Join Date: Jul 2012
Location: Austria
Posts: 1,713
Gone back to v2.6. 2.8 not registering the TC properly... :-(
DanC.Licks is offline  
Reply With Quote
Old Wednesday 5th July 2017, 23:28   #4
Binoseeker
Mostly using spectacles (myopic) with binoculars.
 
Binoseeker's Avatar

 
Join Date: Jun 2012
Location: Sweden
Posts: 521
Dan,
Which TC and lens did you use?
Binoseeker is offline  
Reply With Quote

BF Supporter 2012 Support BirdForum With A Donation

Old Friday 7th July 2017, 07:28   #5
DanC.Licks
AKA Daniel Bradley
 
DanC.Licks's Avatar

 
Join Date: Jul 2012
Location: Austria
Posts: 1,713
400/5.6 L USM and 1.4x Extender III.
It would only register the TC if after turning the camera on I push the lens release button.
DanC.Licks is offline  
Reply With Quote
Old Friday 7th July 2017, 13:27   #6
Binoseeker
Mostly using spectacles (myopic) with binoculars.
 
Binoseeker's Avatar

 
Join Date: Jun 2012
Location: Sweden
Posts: 521
Did you put the ext 1.4 on the lens first, and then put them on the camera?
Binoseeker is offline  
Reply With Quote

BF Supporter 2012 Support BirdForum With A Donation

Old Friday 7th July 2017, 18:07   #7
DanC.Licks
AKA Daniel Bradley
 
DanC.Licks's Avatar

 
Join Date: Jul 2012
Location: Austria
Posts: 1,713
Makes no difference which order you put them on. The camera is always off anyway when I change lenses.
DanC.Licks is offline  
Reply With Quote
Old Sunday 23rd July 2017, 16:25   #8
Tord
Registered User
 
Tord's Avatar

 
Join Date: May 2006
Location: Malmö, Sweden
Posts: 1,985
Quite recently my Canon 400/Metabones adapter setup started to show some weird behavior, hard to describe in detail but in short:
  • After power on the display would sometimes stay black, or sometimes render a lark low contrast image.
  • Consistent focus refusal, regardless of subject. The camera would make half a dozen attempts to acquire focus (click-click-click...) and then either simply give up, or confirm focus even when focus was incorrect. Exception was when turning EVF magnification on, then focus would quite often be acquired (but not always)
This behavior was observed regardless of camera body (EM-1 and EM-1 Mark 2).
I was thinking about giving up and putting up the lens and extender for sale, but before doing so I decided to install the latest FW (2.8). Much to my surprise the setup now works as it should and with what I perceive clearly improved performance (AF acquistion/accuracy) compared to before I updated the adapter. Need to give the lens a workout in field to confirm this.

And for the sake of completess the lens focal lens is reported as it should, 400/566 mm.
__________________

My Gallery on 500px
Tord is offline  
Reply With Quote

BF Supporter 2013 2014 2015 2016 2017 Support BirdForum With A Donation

Old Sunday 30th July 2017, 19:53   #9
DanC.Licks
AKA Daniel Bradley
 
DanC.Licks's Avatar

 
Join Date: Jul 2012
Location: Austria
Posts: 1,713
Tord,
I have found several times that when the Metabones acts up, reloading the firmware does the trick.
I am sticking with 2.6. 2.8 would not register the Mark III Extender and the exposure would be off by one stop. Seems to work better with the Mark II. I keep checking for a minor update, but nothing yet. Sometimes a newer version shows up when you hit the download button, like V2.7b.exe.
DanC.Licks is offline  
Reply With Quote
Old Monday 31st July 2017, 10:53   #10
Tord
Registered User
 
Tord's Avatar

 
Join Date: May 2006
Location: Malmö, Sweden
Posts: 1,985
Quote:
Originally Posted by DanC.Licks View Post
Tord,
I have found several times that when the Metabones acts up, reloading the firmware does the trick.
Hi Dan,

If someone else than me experienced this it indicates there is an issue with the FW becoming corrupt, or saving bad data, causing it to behave incorrectly. That's not good - what if it happens while on a photo session? Worse case is if the loader itself gets corrupted then there is no way to re-load the FW.


Do you remember what preceded this? Like camera lock-up having to take out battery to bring it to life again? (Has happened to me a few times).

We should report this to Metabones.
__________________

My Gallery on 500px
Tord is offline  
Reply With Quote

BF Supporter 2013 2014 2015 2016 2017 Support BirdForum With A Donation

Old Monday 31st July 2017, 21:26   #11
Binoseeker
Mostly using spectacles (myopic) with binoculars.
 
Binoseeker's Avatar

 
Join Date: Jun 2012
Location: Sweden
Posts: 521
I have recently installed FW 2.8. It seems to work ok so far.
It shows 1200mm in exifdata when using Sigma C @ 600m together with Ext 2x mkIII.

I am using E-M1 MkI.
Binoseeker is offline  
Reply With Quote

BF Supporter 2012 Support BirdForum With A Donation

Old Sunday 6th August 2017, 18:07   #12
DanC.Licks
AKA Daniel Bradley
 
DanC.Licks's Avatar

 
Join Date: Jul 2012
Location: Austria
Posts: 1,713
I am sure they know about it. As I remember the problems were usually right in the beginning. I can't remember a firmware going belly up on me once it was running correctly. I stupidly loaded 2.7 the evening before a trip to Hungary, but fortunately, I had my laptop with me and could revert back to 2.6 in the evening after a day of problems with the Extender.
I never had a case where it showed the same behavior as you were experiencing. Usually if something hangs a quick push of the lens release button reactivates it.
DanC.Licks is offline  
Reply With Quote
Old Thursday 14th September 2017, 20:57   #13
Binoseeker
Mostly using spectacles (myopic) with binoculars.
 
Binoseeker's Avatar

 
Join Date: Jun 2012
Location: Sweden
Posts: 521
version 2.9 out

I haven´t tried it yet.... / Anders

Name: Firmware update V2.9 for for Canon EF to Micro Four Thirds Smart AdapterTM/Speed BoosterTM
Release date: 14 Sep 2017
Benefits and improvements:
Fixed IBIS effectiveness issue with EF400/5.6L USM when used in conjunction with EF Extenders.
EXIF improvements.
New custom function allows user to manually dial-in the multiplier of a teleconverter if it is not automatically detected (e.g. certain third-party teleconverters).
Fixed manual focus distance scale display on Panasonic (requires lens with distance information).
Tamron 17-50/2.8 VC B005 stability improvement (although still not recommended for use with Metabones).
Binoseeker is offline  
Reply With Quote

BF Supporter 2012 Support BirdForum With A Donation

Old Tuesday 19th September 2017, 21:51   #14
Binoseeker
Mostly using spectacles (myopic) with binoculars.
 
Binoseeker's Avatar

 
Join Date: Jun 2012
Location: Sweden
Posts: 521
Focus speed test with v.2.9.

I installed v.2.9 now and checked focus speed with lenscap on, on my sigma C 150-600mm @ 600mm with E-M1 Mk I. I measured time for focus going from infinity to shortest distance and back. It took 6 s, with v.2.8 it took 7 s, so that is an improvement of 1 s.

Sometimes, when focus was going from infinity, it stopped at shortest distance, i had to re-press the shutter button to make it continue the focus movement.
Maybe that could be an improvement to get rid of those stops to v.2.10.

I hope I can test the gear with the new version outdoors coming weekend.
Binoseeker is offline  
Reply With Quote

BF Supporter 2012 Support BirdForum With A Donation

Old Tuesday 26th September 2017, 21:16   #15
Binoseeker
Mostly using spectacles (myopic) with binoculars.
 
Binoseeker's Avatar

 
Join Date: Jun 2012
Location: Sweden
Posts: 521
I tested the camera gear with MB v 2.9 this weekend, and it seems to work ok.
Binoseeker is offline  
Reply With Quote

BF Supporter 2012 Support BirdForum With A Donation

Old Thursday 28th September 2017, 18:53   #16
DanC.Licks
AKA Daniel Bradley
 
DanC.Licks's Avatar

 
Join Date: Jul 2012
Location: Austria
Posts: 1,713
I have taken the leap and got an Oly 300/4 Pro and MC-14. Samples here:
https://www.flickr.com/photos/421620...57686900108123
I did load v2.9 though and it seems to work fine with the 400/5.6, but not any faster as far as I can tell.
So my Metabones days are either numbered, or simply over. I have enjoyed it, but the 300/4 + MC-14 is sharper than the Canon and has far less CA, and the AF is amazingly fast!
DanC.Licks is offline  
Reply With Quote
Advertisement
Reply


Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Metabones Qu - Canon EF to MFT T Smart Adapter rka Micro Four Thirds 4/3 Photography 12 Wednesday 21st June 2017 11:41
Metabones Smart Adapter for Canon lenses on mFT DanC.Licks Olympus 6 Monday 26th October 2015 06:10
Canon DPP Version 4 - Convert and Save Colin Photoshop, Paintshop and Printing 0 Tuesday 12th May 2015 22:54
Anyone used the 7dayshop version of the Canon LP-E4? davem Canon 2 Thursday 25th March 2010 18:46

{googleads}
£100 Cashback on Opticron DBA VHD Binoculars. Click to find out more.

Fatbirder's Top 1000 Birding Websites

Help support BirdForum

Page generated in 0.18439198 seconds with 25 queries
All times are GMT. The time now is 18:28.