Join for FREE
It only takes a minute!
Discover the ZEISS Digital Nature Hub

Welcome to BirdForum.
BirdForum is the net's largest birding community, dedicated to wild birds and birding, and is absolutely FREE! You are most welcome to register for an account, which allows you to take part in lively discussions in the forum, post your pictures in the gallery and more.

Strange problem of Canon A95 with connecting to computer via usb cable

Reply
 
Thread Tools Rate Thread
Old Monday 26th September 2005, 17:16   #1
stchong
Registered User

 
Join Date: Sep 2005
Location: China
Posts: 2
Unhappy Strange problem of Canon A95 with connecting to computer via usb cable

Hi, guys. I just faced a very strange problem. I try to download the photoes from a canon A95 to a computer with windows 2003. But the computer only can detect with showing a message something like "Digital Still camera is detected and ready to be used." That's all. then I can not found any item in "my computer", normally there is an icon called Canon A95, and I can click it to view the photoes, I also can not find the camera in "Scanners and Cameras" from "Control Panel". I try to install all the software in the CD from Canon, but it didn't work. I try the same thing on a computer with win 2000, same problem. But the funny thing is, it works when I try it on several computers with Windows XP.

Anybody knows what the problem is? I hope all the experts here could help me, thank you.
stchong is offline  
Reply With Quote
Old Monday 26th September 2005, 17:21   #2
KC Foggin
Super Moderator
BF Supporter 2020
 
KC Foggin's Avatar

 
Join Date: Nov 2002
Location: Myrtle Beach SC "Smiling Faces, Beautiful Places"
Posts: 283,265
Hi Stchong and a warm welcome to you from those of us on staff here at BirdForum

Not sure about the particular problem you are having but someone should have a few suggestions for you before long.

I have always found a card reader to be much easier to use and a lot less drain on the camera battery. They are quite inexpensive. Good luck.
__________________
KC a/k/a common KC
KC Foggin is online now  
Reply With Quote

BF Supporter 2004 2005 2006 2007 2008 2009 2010 2011 2012 2013 2014 2015 2016 2017 2018 2019 2020 Support BirdForum With A Donation

Old Monday 26th September 2005, 17:25   #3
Andrew Rowlands
Registered User
 
Andrew Rowlands's Avatar

 
Join Date: Mar 2003
Location: Wales.
Posts: 5,974
Hi stchong, Welcome to Birdforum.

I don't have an A95 but I can fire up a Windows2003 Server to test one of my cameras on - I'll try it later - maybe someone else knows.

Do you have an extra drive that shows up in Windows Explorer when the A95 is attached? Maybe it's just named 'Removeable Drive' or similar?

Cheers,

Andy.
Andrew Rowlands is offline  
Reply With Quote

BF Supporter 2004 2005 2006 Support BirdForum With A Donation

Old Tuesday 27th September 2005, 16:18   #4
stchong
Registered User

 
Join Date: Sep 2005
Location: China
Posts: 2
Thanks K.C and Andy's reply.
As I said, I can not find any extra drive shown in Windows Explorer, that's the funny point.

Yup, if this problem can not be solved, I will go to buy a card reader, that's the only way.

Anyway, thanks, guys.
stchong is offline  
Reply With Quote
Old Tuesday 27th September 2005, 17:06   #5
Keith Reeder
Watch the birdie...
 
Keith Reeder's Avatar

 
Join Date: Dec 2003
Location: Blyth, Northumberland, NE England
Posts: 11,038
Hi Stchong,

I must admit that I use a card reader to get images off my A95 - it's simply quicker and easier to do it this way.
__________________
Keith Reeder

Canon 7D, Sigma 120-300mm f/2.8 OS, TCs.
www.capture-the-moment.co.uk
Keith Reeder is offline  
Reply With Quote

BF Supporter 2006 2007 Support BirdForum With A Donation

Old Tuesday 27th September 2005, 17:09   #6
scampo
Steve Campsall
 
scampo's Avatar

 
Join Date: Aug 2003
Location: Leicestershire, UK
Posts: 6,274
Quote:
Originally Posted by stchong
Hi, guys. I just faced a very strange problem. I try to download the photoes from a canon A95 to a computer with windows 2003. But the computer only can detect with showing a message something like "Digital Still camera is detected and ready to be used." That's all. then I can not found any item in "my computer", normally there is an icon called Canon A95, and I can click it to view the photoes, I also can not find the camera in "Scanners and Cameras" from "Control Panel". I try to install all the software in the CD from Canon, but it didn't work. I try the same thing on a computer with win 2000, same problem. But the funny thing is, it works when I try it on several computers with Windows XP.

Anybody knows what the problem is? I hope all the experts here could help me, thank you.
I have WinXP but yours might be similar: go into Control Panel and, with the extra drive switched on (i.e. with the camera on), click on "Administrative Tools" then "Computer Management" followed by "Disk Management". Look in there - it shows all the "hard dirves" on your PC. Does the drive show up? It's possible you have a clash of allocated drive letters or such like and need to give the new drive a different letter. I have had similar problems and have solved them this way.
__________________
Steve
"...when the cities lie at the monster’s feet there are left the mountains."
Robinson Jeffers, "Shine, Perishing Republic"
scampo is offline  
Reply With Quote
Advertisement
Reply


Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Shutter release bracket and cable for Canon A95. senatore Digiscoping cameras 9 Saturday 10th September 2005 13:58
Some basic Canon EOS 10D questions Leif Canon 8 Sunday 14th November 2004 14:16
Is purple fringing a problem on Canon A80? falco Canon 9 Friday 14th May 2004 12:41
Electric Cable Release Canon G-3 DoveKeeper Technique 2 Friday 21st November 2003 23:08

{googleads}

Fatbirder's Top 1000 Birding Websites

Help support BirdForum

Page generated in 0.09943509 seconds with 18 queries
All times are GMT. The time now is 00:08.