Join for FREE
It only takes a minute!
More discoveries. NEW: Zeiss Victory SF 32

Welcome to BirdForum.
BirdForum is the net's largest birding community, dedicated to wild birds and birding, and is absolutely FREE! You are most welcome to register for an account, which allows you to take part in lively discussions in the forum, post your pictures in the gallery and more.

Leica Apo 62 problem

Reply
 
Thread Tools Rate Thread
Old Thursday 9th May 2013, 16:28   #1
Charltonfan
Registered User

 
Join Date: Dec 2007
Location: Hextable Kent
Posts: 73
Leica Apo 62 problem

I've hinted at this in a previous post with no response. My Apo 62 angled scope seems to have something slightly loose inside. When turning the scope body over an audible 'click' can be heard and felt in the black body part of the housing. It's like something weighty is moving slightly inside the scope if that makes sense. Optically all is perfect. Just wondering if anyone else has experienced this or any ideas what it might be. I have an authorised dealer not too far from where I live who do repairs but don't want to spend out unnecessarily
Charltonfan is offline  
Reply With Quote
Old Thursday 9th May 2013, 18:50   #2
Richard Scott
Registered User

 
Join Date: Nov 2004
Location: South Yorkshire
Posts: 354
I've just checked mine and it makes a slight click when turned upside down. I can't feel anything though. Its no big deal in my opinion.
Richard Scott is offline  
Reply With Quote
Old Thursday 9th May 2013, 19:20   #3
Charltonfan
Registered User

 
Join Date: Dec 2007
Location: Hextable Kent
Posts: 73
Rich, sounds like it could be a similar thing. It's quite subtle but I feel like all the internals just shift ever so slightly accompanied by a little click. Strange
Charltonfan is offline  
Reply With Quote
Old Sunday 12th May 2013, 16:32   #4
Liquid Len
Registered User

 
Join Date: Jul 2008
Location: Yorkshire
Posts: 88
Checked mine too and I get no clicks or strange sounds of any kind when moving it around after 9 years of use. If all seems well optically and no other signs of anything amiss, possibly best to keep an eye on it & leave well alone unless absolutely necessary. Presumably it wasn't like it when you bought it and has 'developed' over time? If mine had been, it would have stayed in the shop!

LL
Liquid Len is offline  
Reply With Quote
Old Sunday 12th May 2013, 17:36   #5
Roy Goldsmith
Registered User
 
Roy Goldsmith's Avatar

 
Join Date: Apr 2013
Location: Norfolk UK
Posts: 167
Re Apo 62

Quote:
Originally Posted by Charltonfan View Post
I've hinted at this in a previous post with no response. My Apo 62 angled scope seems to have something slightly loose inside. When turning the scope body over an audible 'click' can be heard and felt in the black body part of the housing. It's like something weighty is moving slightly inside the scope if that makes sense. Optically all is perfect. Just wondering if anyone else has experienced this or any ideas what it might be. I have an authorised dealer not too far from where I live who do repairs but don't want to spend out unnecessarily
If you have a fault with your scope your dealer should be able to return it to Leica in Germany for you at no cost to you. Take it to the dealer you purchased it from and ask them. Leica repairs are all now carried out in Germany. My Apo 62 was sent back as the eyepiece socket broke away from the body. It took about around two weeks to get it back to my dealer all work done was FOC. So it will be worth asking.
Regards Roy
Roy Goldsmith is offline  
Reply With Quote
Old Sunday 12th May 2013, 21:00   #6
Charltonfan
Registered User

 
Join Date: Dec 2007
Location: Hextable Kent
Posts: 73
Cheers for the replies. I bought the scope second hand so no warranty. Got it off fleabay. Could have raised a dispute and returned it as seller said he was not aware of any problem with it but as i have said it is optically perfect with mint lenses and the issue I have with it is subtle plus got it for a good price. I really am very happy with it but thought others might know if somethings not right. I'm going to keep an eye on it so to speak having used it about a dozen times with no problem
Charltonfan is offline  
Reply With Quote
Advertisement
Reply


Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Leica APO 77 Televid focusing problem goldenorbs Digiscoping Accessories 0 Monday 8th November 2010 14:03
Leica APO 77 Televid focusing problem goldenorbs The Birdforum Digiscoping Forum 0 Sunday 7th November 2010 12:08
Leica 8x42BN Problem fi8she4r Leica 25 Saturday 8th May 2010 16:55
Leica Ultravid problem Sleeper Leica 26 Wednesday 18th March 2009 18:28
problem with Leica 8x50 BN shilo Leica 3 Friday 8th June 2007 12:07

{googleads}

Fatbirder's Top 1000 Birding Websites

Help support BirdForum

Page generated in 0.15529394 seconds with 20 queries
All times are GMT. The time now is 04:48.