Join for FREE
It only takes a minute!
Zeiss - Always on the lookout for something special – Shop now

Welcome to BirdForum.
BirdForum is the net's largest birding community, dedicated to wild birds and birding, and is absolutely FREE! You are most welcome to register for an account, which allows you to take part in lively discussions in the forum, post your pictures in the gallery and more.

Canon EOS R w/ Tamron 150-600 G2 focus issue

Reply
 
Thread Tools Rate Thread
Old Thursday 3rd October 2019, 19:15   #1
elspedo
Photography degree student

 
Join Date: Aug 2008
Location: lancashire
Posts: 43
Canon EOS R w/ Tamron 150-600 G2 focus issue

Hi all, i'm having an issue with the Tamron 150-600 G2 on my EOS R.

When the camera goes into power saving mode, the lens will not focus again when the camera has powered back on. It just wildly hunts and squeals a little bit at the short focussing distance.

If I turn the camera off and remount the lens it works again but by that time anything I had pointed my camera at has made a sharp exit.

I've updated the firmware in the camera to 1.4 but want to know if anyone else has had this issue before I go about purchasing the dock to update the lens, as if that's not going to fix it, I may as well save the money and send the lens back.

I've tried to contact Tamron through their web form but had no response yet so any help is appreciated.
elspedo is offline  
Reply With Quote
Old Thursday 3rd October 2019, 21:25   #2
seawatcher
Registered User

 
Join Date: Feb 2004
Location: no fixed abode
Posts: 121
I read somewhere that the newer Tamron 150-600 G2 lenses work fine with the EOS-R and EOS-RP, whereas with older versions you need to use the tap-in console to update the lens firmware. I am afraid I cannot find the website where I read this (just did a search).
I use the EOS-RP, and have an older G2 manufactured before the camera was first launched. According to the Tamron website, the serial number indicated that I needed to update the firmware for the lens. Undeterred, I attached the EOS-RP to the G2 lens. The first few times it did make horrible noises, especially after powering down. Yet now, without me having done anything, this combination works a treat. That does not mean to say that your lens will stop hunting for focus, in which case you need to update the firmware, or ask your dealer to exchange for a lens with a newer serial number that is already updated to be used with the EOS-R or RP.
seawatcher is offline  
Reply With Quote
Old Friday 18th October 2019, 14:11   #3
elspedo
Photography degree student

 
Join Date: Aug 2008
Location: lancashire
Posts: 43
Thanks for the reply, I had the lens in to be updated and it's come back with exactly the same problem so seems like a faulty lens.
elspedo is offline  
Reply With Quote
Advertisement
Reply


Thread Tools
Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Baader hyp 1V Longrange focus issue ranger4 Kowa 7 Thursday 1st August 2019 15:08
MeoStar 8x42 focus issue Kuhberg Meopta 6 Friday 4th August 2017 22:05
7Dmk1 plus canon 100-400 focus issue? shorebirder Canon 1 Wednesday 27th July 2016 20:13
Canon Powershot SX50 HS focus issue ebwilderae Photo Critique 6 Sunday 1st September 2013 05:58
7d soft focus issue Richard Ford Canon 58 Friday 9th July 2010 14:03

{googleads}

Fatbirder's Top 1000 Birding Websites

Help support BirdForum

Page generated in 0.13868690 seconds with 17 queries
All times are GMT. The time now is 13:27.