• BirdForum is the net's largest birding community dedicated to wild birds and birding, and is absolutely FREE!

    Register for an account to take part in lively discussions in the forum, post your pictures in the gallery and more.

Canon EOS R w/ Tamron 150-600 G2 focus issue (1 Viewer)

elspedo

Photography degree student
Hi all, i'm having an issue with the Tamron 150-600 G2 on my EOS R.

When the camera goes into power saving mode, the lens will not focus again when the camera has powered back on. It just wildly hunts and squeals a little bit at the short focussing distance.

If I turn the camera off and remount the lens it works again but by that time anything I had pointed my camera at has made a sharp exit.

I've updated the firmware in the camera to 1.4 but want to know if anyone else has had this issue before I go about purchasing the dock to update the lens, as if that's not going to fix it, I may as well save the money and send the lens back.

I've tried to contact Tamron through their web form but had no response yet so any help is appreciated.
 

seawatcher

Well-known member
I read somewhere that the newer Tamron 150-600 G2 lenses work fine with the EOS-R and EOS-RP, whereas with older versions you need to use the tap-in console to update the lens firmware. I am afraid I cannot find the website where I read this (just did a search).
I use the EOS-RP, and have an older G2 manufactured before the camera was first launched. According to the Tamron website, the serial number indicated that I needed to update the firmware for the lens. Undeterred, I attached the EOS-RP to the G2 lens. The first few times it did make horrible noises, especially after powering down. Yet now, without me having done anything, this combination works a treat. That does not mean to say that your lens will stop hunting for focus, in which case you need to update the firmware, or ask your dealer to exchange for a lens with a newer serial number that is already updated to be used with the EOS-R or RP.
 

elspedo

Photography degree student
Thanks for the reply, I had the lens in to be updated and it's come back with exactly the same problem so seems like a faulty lens.
 

noellenchris

New member
Thanks for the reply, I had the lens in to be updated and it's come back with exactly the same problem so seems like a faulty lens.

I had the same issue. I figured it out yesterday. Canon has an issue with this lens, go to power settings and enable Auto turn off after 2-3min. This will cycle the power off and when it wakes by pressing any button it will be fine just like manually turning off and back on to fix the focus issue. I thought it was my lens too and was going to send in my lens and camera. But I tried resetting my settings to default. In manual the lens was fine. But my C1-3 wasn't reset and it would still do the focus issue. I then narrowed down to the above setting. Good luck. I also reported this to Tamron and Canon. Hopefully Canon can update / fix the issue soon with a firmware release.

Chris
 

stevo

Well-known member
It's not canon with the issue with the lens,Canon design their cameras to be used with canon made lenses.When 3rd party manufacturers design a lens it's to be used across several different makers bodies,done through reverse engineering.
 

Users who are viewing this thread

Top