• BirdForum is the net's largest birding community dedicated to wild birds and birding, and is absolutely FREE!

    Register for an account to take part in lively discussions in the forum, post your pictures in the gallery and more.

Issue with Nikon D7000, 300mm f4+1,4 TC (1 Viewer)

nikothomsen

Well-known member
I have been shooting with my D7000 for roughly four years now, using a bunch of different lenses with more or less no problems. I love my 300mm f4 and I experience no trouble when shooting it directly on the body.

My problem arises when i mount my TC. The best way I can describe the problem is that the contact either between the lens and TC, or TC or body loosens. When i do not physically twist the lens to tighten the contact, I cannot focus and therefore i cannot shoot.

I have noticed that temperature does make a difference. When I am shooting in a very hot or cold environment the problem becomes worse, and sometimes me twisting the lens, as hard as I can, is not enough.

Hoping there's some sort of easy fix out there.. Thanks for your help!
 

opticoholic

Well-known member
I would try to borrow another camera and see if you can reproduce the issue. If not, then you would pretty much know the issue is with the join between the TC and the lens... If so, you might try to borrow and try a different TC. If a different body eliminates the issue, you might consider upgrading your D7000.

Good luck,
Dave
 

mpe

Well-known member
Is it a Nikon TC or third party? I had the similar problem with Kenko TC and that was why I upgraded to Nikon.

Try to tighten all screws on the TC and clean electrical contacts on both lens and TC.
 

nikothomsen

Well-known member
It is a Nikon TC, grey market however. I knew not to have too high expectations but now it is getting on my nerves!
 

pe'rigin

Well-known member
It sounds that by tightening you have damaged the TC thread or the locking flange, I would refrain from using this TC on the Nikon, otherwise you could damage the camera mount and risk the contacts with other lenses.
If you have a magnifying glass look carefully at the inner locking flange (camera side) and the contacts, as suggested give it a blow and clean, looking for any warping, or marks on the alloy.
If damaged then it would probably be cheaper to get a new TC, than repair.
 

DFBHeron

Well-known member
I have been shooting with my D7000 for roughly four years now, using a bunch of different lenses with more or less no problems. I love my 300mm f4 and I experience no trouble when shooting it directly on the body.

My problem arises when i mount my TC. The best way I can describe the problem is that the contact either between the lens and TC, or TC or body loosens. When i do not physically twist the lens to tighten the contact, I cannot focus and therefore i cannot shoot.

I have noticed that temperature does make a difference. When I am shooting in a very hot or cold environment the problem becomes worse, and sometimes me twisting the lens, as hard as I can, is not enough.

Hoping there's some sort of easy fix out there.. Thanks for your help!

I had this happen too, and remember reading that it had to do with wires/contacts loosening within the TC. I don't recall there being an easy fix, but I did take it apart to try (no luck there!). So, I bought another, and that solved the issue.
 

Users who are viewing this thread

Top