• Welcome to BirdForum, the internet's largest birding community with thousands of members from all over the world. The forums are dedicated to wild birds, birding, binoculars and equipment and all that goes with it.

    Please register for an account to take part in the discussions in the forum, post your pictures in the gallery and more.
ZEISS DTI thermal imaging cameras. For more discoveries at night, and during the day.

Merlin explore location frozen (3 Viewers)


I've been using Merlin for a while and often use the explore function to see what might be around in a place I'm traveling to. When typing in the location, it used to autofill some options and you could click one, or just pick from the map. Starting maybe a week ago, it won't do anything. You can type in whatever but nothing comes up in autofill, and won't search when you press enter. And if you try to select from map, as soon as you click "use this location" it goes back to the previous screen. It doesn't necessarily freeze, it just doesn't do anything. Android phone BTW.

I uninstalled and reinstalled the app and reloaded the bird packs, still the same problem. 🤷‍♂️
It sounds quite possibly to be a bug introduced by a recent update. The obvious option is just to sit it out and wait for the next update which, one hopes, may fix the bug. Another is to register now for Merlin's Beta program and install that (see Merlin's Google Play page) which may (or may not) fix your issue (I have successfully done this myself in the past to fix a different bug in Merlin). If you don't want to stay part of the Beta program you can de-register from it (via the Google Play page) at some future date.
Interesting idea, you may be right. I checked and it's on version 3.0.3, but the play store says the last update was Dec 27th. I'll try the beta thing and see how that goes.
My phone has been doing weird stuff in other apps so maybe it's just my phone. Has anyone else seen this issue?
Do you have a way to save all personal content on your phone and thereafter force to factory reset? if that does not work, then it might be time for a new phone.
Have you tried a soft reset (without losing any data; for me, it involves pressing the power button and the decrease volume button precisely at the same time for a while)?
I'd rather not go to the level of a full factory reset. I usually keep phones for 3-4 years until I can't update the OS and important apps won't update anymore. Almost entirely because I don't want to deal with reloading all my apps and signing in to everything. Luckily the soft reset fixed it. Thanks, I'm not sure what the issue was, but I guess it doesn't matter.
Would be interesting to know if you had you previously tried to fix your issue by just turning the phone off and on again? Always the first thing to try when anything computerish starts behaving weirdly, and I hadn't thought to ask if you had/hadn't done that. As I understand it, a soft reset in Android is (in its effect) the same thing as restarting, and is just an alternative way of achieving that (eg I've used it in the past when a phone has got so confused that it won't power down by normal means).

Users who are viewing this thread